请把这个指标公式改成选股公式

2024-04-19 13:59

1. 请把这个指标公式改成选股公式

牛股起爆选股公式:

DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
二次金叉1:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(低位金叉,21)=2;
TJ1:=低位金叉 OR 二次金叉1;
LJPK:=(C+H+O+L)/4;
MCC:=XMA(LJPK,20)*(1+80/1000);
MRR:=XMA(LJPK,32)*(1-100/1000);
ZXX:=(MCC+MRR)/2;
ZXA:=(MRR+ZXX)/2;
TJ2:=REF(L,1)<ZXA;
TJ3:=TJ2 AND COUNT(TJ2,6)>=6;
TJ8:=REF(C,1)/REF(C,5)=MA(C,24) AND EXIST(V/REF(V,1)>=2,5) AND C>REF(C,1);
牛股起爆:TJ3 AND TJ8;


门庭若市选股公式:

DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
二次金叉1:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(低位金叉,21)=2;
TJ1:=低位金叉 OR 二次金叉1;
LJPK:=(C+H+O+L)/4;
MCC:=XMA(LJPK,20)*(1+80/1000);
MRR:=XMA(LJPK,32)*(1-100/1000);
ZXX:=(MCC+MRR)/2;
ZXA:=(MRR+ZXX)/2;
TJ2:=REF(L,1)<ZXA;
TJ3:=TJ2 AND COUNT(TJ2,6)>=6;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA17:=MA(C,17);
MA20:=MA(C,20);
MA24:=MA(C,24);
MA30:=MA(C,30);
MA43:=MA(C,43);
MA72:=MA(C,72);
MA200:=MA(C,200);
TJ4:=MA5>=MA24 AND MA24>=MA72 AND MA72>=MA200;
TJ5:=MA10>=MA30 AND MA20>=MA30;
TJ7:=TJ4 OR TJ5;
AAA:=EVERY(V=1.5;
牛股:=TJ2 AND TJ3 AND TJ7;
牛股出炉:=AAA AND 牛股 AND C>=MA(C,24);
门庭若市:COUNT(EXIST(牛股出炉,6),6)>=2 AND C>REF(C,1) AND REF(C,2)O;


疯狂箭头选股公式:

DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
二次金叉1:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(低位金叉,21)=2;
TJ1:=低位金叉 OR 二次金叉1;
LJPK:=(C+H+O+L)/4;
MCC:=XMA(LJPK,20)*(1+80/1000);
MRR:=XMA(LJPK,32)*(1-100/1000);
ZXX:=(MCC+MRR)/2;
ZXA:=(MRR+ZXX)/2;
TJ2:=REF(L,1)<ZXA;
TJ3:=TJ2 AND COUNT(TJ2,6)>=6;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA17:=MA(C,17);
MA20:=MA(C,20);
MA24:=MA(C,24);
MA30:=MA(C,30);
MA43:=MA(C,43);
MA72:=MA(C,72);
MA200:=MA(C,200);
TJ4:=MA5>=MA24 AND MA24>=MA72 AND MA72>=MA200;
TJ5:=MA10>=MA30 AND MA20>=MA30;
TJ7:=TJ4 OR TJ5;
AAA:=EVERY(V=1.5;
牛股:=TJ2 AND TJ3 AND TJ7;
牛股出炉:=AAA AND 牛股 AND C>=MA(C,24);
门庭若市:=COUNT(EXIST(牛股出炉,6),6)>=2 AND C>REF(C,1) AND REF(C,2)O;
疯狂箭头:IF(BARSLASTCOUNT(EXIST(门庭若市,3))>=2,门庭若市,0);

请把这个指标公式改成选股公式

2. 请高手帮我把这条公式编写成出现绝对顶部和牛股起爆两条选股公式谢谢

G1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
G2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
G3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
G4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(30,G1))<2 AND BARSLAST(CROSS(G1,50))<2;
B:=BARSLAST(CROSS(G4,G1))G4;
E:=G1>60 AND G4>70;
牛股起爆点:A AND B AND E;


日:=150;
昨前:=3; 
高1:=REF(HHV(H,日),昨前); 
顶:=REFDATE(高1,DATE); 
绝顶:=REFDATE(顶,DATE);
跑:绝顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O));

3. 请高手把这个公式改成通达信选股公式,选出当天出现的【黑马起爆点】信号的股票,急需,谢谢!!!


请高手把这个公式改成通达信选股公式,选出当天出现的【黑马起爆点】信号的股票,急需,谢谢!!!

4. 通达信指标改选股

该指标使用未来函数,请谨慎使用

5. 请老师将下面的寻宝小人,指标公式改为选股公式

DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);DEA:=EMA(DIFF,9);MACD:=(DIFF-DEA)*2;低位金叉:=CROSS(DIFF,DEA) AND DIFF=6;MA5:=MA(C,5);MA10:=MA(C,10);MA17:=MA(C,17);MA20:=MA(C,20);MA24:=MA(C,24);MA30:=MA(C,30);MA43:=MA(C,43);MA72:=MA(C,72);MA200:=MA(C,200);TJ4:=MA5>=MA24 AND MA24>=MA72 AND MA72>=MA200;TJ5:=MA10>=MA30 AND MA20>=MA30;TJ7:=TJ4 OR TJ5;牛股:=TJ2 AND TJ3 AND TJ7;牛股考量:=(TJ1 AND TJ2)*66;AAA:=EVERY(V=1.5;牛股出炉:AAA AND 牛股 AND C>=MA(C,24);

请老师将下面的寻宝小人,指标公式改为选股公式

6. 请高手帮忙修改主图指标公式,另改为选股公式谢谢!!!

  该指标使用了DCLOSE(不定期收盘价),它属于未来函数!  
  再一个,该指标就是一个普通的均线指标添加了其它的语句,不建议你做选股公式。

7. 哪位能人能把这个指标编写成选股公式,感激不尽。

{寻宝状元人}
LJPK:=(C+H+O+L)/4;
MCC:=XMA(LJPK,20)*(1+80/1000);
MRR:=XMA(LJPK,32)*(1-100/1000);
ZXX:=(MCC+MRR)/2;
ZXA:=(MRR+ZXX)/2;
TJ2:=REF(L,1)<ZXA;
{STICKLINE(TJ2,15,85,5,0),COLORFF7F00};
TJ3:=TJ2 AND COUNT(TJ2,6)>=6;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA17:=MA(C,17);
MA20:=MA(C,20);
MA24:=MA(C,24);
MA30:=MA(C,30);
MA43:=MA(C,43);
MA72:=MA(C,72);
MA200:=MA(C,200);
TJ4:=MA5>=MA24 AND MA24>=MA72 AND MA72>=MA200;
TJ5:=MA10>=MA30 AND MA20>=MA30;
TJ7:=TJ4 OR TJ5;
牛股:=TJ2 AND TJ3 AND TJ7;
AAA:=EVERY(V=1.5;
牛股出炉:=AAA AND 牛股 AND C>=MA(C,24);
寻宝状元人:牛股出炉;

{门庭若市}
LJPK:=(C+H+O+L)/4;
MCC:=XMA(LJPK,20)*(1+80/1000);
MRR:=XMA(LJPK,32)*(1-100/1000);
ZXX:=(MCC+MRR)/2;
ZXA:=(MRR+ZXX)/2;
TJ2:=REF(L,1)<ZXA;
{STICKLINE(TJ2,15,85,5,0),COLORFF7F00};
TJ3:=TJ2 AND COUNT(TJ2,6)>=6;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA17:=MA(C,17);
MA20:=MA(C,20);
MA24:=MA(C,24);
MA30:=MA(C,30);
MA43:=MA(C,43);
MA72:=MA(C,72);
MA200:=MA(C,200);
TJ4:=MA5>=MA24 AND MA24>=MA72 AND MA72>=MA200;
TJ5:=MA10>=MA30 AND MA20>=MA30;
TJ7:=TJ4 OR TJ5;
牛股:=TJ2 AND TJ3 AND TJ7;
AAA:=EVERY(V=1.5;
牛股出炉:=AAA AND 牛股 AND C>=MA(C,24);
门庭若市1:=(IF(COUNT(EXIST(牛股出炉,6),6)>=2,牛股出炉,DRAWNULL));
门庭若市:门庭若市1 AND C>REF(C,1) AND REF(C,2)O;

{疯狂箭头}
LJPK:=(C+H+O+L)/4;
MCC:=XMA(LJPK,20)*(1+80/1000);
MRR:=XMA(LJPK,32)*(1-100/1000);
ZXX:=(MCC+MRR)/2;
ZXA:=(MRR+ZXX)/2;
TJ2:=REF(L,1)<ZXA;
{STICKLINE(TJ2,15,85,5,0),COLORFF7F00};
TJ3:=TJ2 AND COUNT(TJ2,6)>=6;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA17:=MA(C,17);
MA20:=MA(C,20);
MA24:=MA(C,24);
MA30:=MA(C,30);
MA43:=MA(C,43);
MA72:=MA(C,72);
MA200:=MA(C,200);
TJ4:=MA5>=MA24 AND MA24>=MA72 AND MA72>=MA200;
TJ5:=MA10>=MA30 AND MA20>=MA30;
TJ7:=TJ4 OR TJ5;
牛股:=TJ2 AND TJ3 AND TJ7;
AAA:=EVERY(V=1.5;
牛股出炉:=AAA AND 牛股 AND C>=MA(C,24);
门庭若市1:=(IF(COUNT(EXIST(牛股出炉,6),6)>=2,牛股出炉,DRAWNULL));
门庭若市:=(门庭若市1 AND C>REF(C,1) AND REF(C,2)O)*75;
门庭若市3:=门庭若市/75;
疯狂箭头:(IF(BARSLASTCOUNT(EXIST(门庭若市3,3))>=2,门庭若市3,DRAWNULL))*80;

{抢钱啊}
LJPK:=(C+H+O+L)/4;
MCC:=XMA(LJPK,20)*(1+80/1000);
MRR:=XMA(LJPK,32)*(1-100/1000);
ZXX:=(MCC+MRR)/2;
ZXA:=(MRR+ZXX)/2;
TJ2:=REF(L,1)<ZXA;
TJ3:=TJ2 AND COUNT(TJ2,6)>=6;
TJ8:=REF(C,1)/REF(C,5)=MA(C,24) AND EXIST(V/REF(V,1)>=2,5) AND C>REF(C,1);
牛股起爆:=TJ3 AND TJ8;
抢钱啊:牛股起爆;


股票公式专家团为你解答,希望能帮到你,祝投资顺利。

哪位能人能把这个指标编写成选股公式,感激不尽。

8. 请高手将下面指标公式改成通达信的选股公式。非常谢谢!!!!

请高手把指标公式例出来!
最新文章
热门文章
推荐阅读